Множественные уязвимости в GraphicsMagick

Дата публикации:
06.06.2008
Всего просмотров:
1387
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-6071
CVE-2008-6070
CVE-2008-6072
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GraphicsMagick 1.x
Уязвимые версии: GraphicsMagick версии до 1.1.14 и 1.2.3

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки проверки границ данных в функции "ReadPALMImage()" в файле coders/palm.c. Удаленный пользователь может с помощью специально сформированного PALM изображения вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки проверки границ данных в функции "DecodeImage()" в файле coders/pict.c. Удаленный пользователь может с помощью специально сформированного PICT изображения вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

3. Уязвимость существует из-за неизвестных ошибок при обработке XCF, DPX и CINEON изображений. Удаленный пользователь может с помощью специально сформированного изображения выполнить произвольный код на целевой системе.

URL производителя: www.graphicsmagick.org

Решение: Установите последнюю версию 1.1.14 или 1.2.3 с сайта производителя.

или введите имя

CAPTCHA