Переполнение буфера в freeSSHd

Дата публикации:
02.06.2008
Дата изменения:
13.04.2009
Всего просмотров:
1645
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
freeSSHd 1.x
Уязвимые версии: freeSSHd 1.2.1, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке SFTP команд. Удаленный пользователь может запросить директорию со слишком длинным именем, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: freesshd.com

Решение: Установите последнюю версию 1.2.1.14 с сайта производителя.

Журнал изменений:

07.06.2008
Добавлен PoC код.
29.03.2009
Изменена секция "Решение"
13.04.2009
Добавлен PoC код.

Ссылки: freeSSHd 1.2.1 Remote Stack Overflow PoC (auth)
FreeSSHD 1.2.1 (Post Auth) Remote SEH Overflow Exploit
FreeSSHd 1.2.1 (rename) Remote Buffer Overflow Exploit (SEH)

или введите имя

CAPTCHA