Несколько уязвимостей в IBM Lotus Domino Web Server

Дата публикации:
21.05.2008
Дата изменения:
21.05.2008
Всего просмотров:
1219
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-2240
CVE-2008-2410
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
IBM Lotus Domino 7.x
IBM Lotus Domino 8.x
IBM Lotus Domino 6.x
Уязвимые версии: IBM Lotus Domino версии до 7.0.3 Fix Pack 1 (FP1) и 8.0.1

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, вызвать отказ в обслуживании и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в сервлете Web контейнера. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за ошибки проверки границ данных в Lotus Domino Web Server. Удаленный пользователь может с помощью слишком длинного HTTP заголовка "Accept-Language" вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.lotus.com/products/product4.nsf/wdocs/dominohomepage

Решение: Установите последнюю версию 7.0.3 Fix Pack 1 (FP1) или 8.0.1 с сайта производителя.

Ссылки: http://www-1.ibm.com/support/docview.wss?uid=swg21303057
http://www-1.ibm.com/support/docview.wss?uid=swg21303296
http://www.mwrinfosecurity.com/publications/mwri_ibm-lotus-domino-accept-language-stack-overflow_2008-05-20.pdf

или введите имя

CAPTCHA