Переполнение буфера в Foxit Reader

Дата публикации:
20.05.2008
Дата изменения:
18.08.2008
Всего просмотров:
1877
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Foxit Reader 2.x
Уязвимые версии: Foxit Reader 2.3 build 2825, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке форматных строк, содержащих плавающую точку, в JavaScript функции "util.printf()". Удаленный пользователь может с помощью специально сформированного PDF файла вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.foxitsoftware.com/pdf/rd_intro.php

Решение: Установите последнюю версию с сайта производителя. Уязвимость будет устранена в версии 2.3 build 2912

Журнал изменений:


10.08.2008
Изменена секция "Решение".

Ссылки: Secunia Research: Foxit Reader "util.printf()" Buffer Overflow

или введите имя

CAPTCHA