SQL-инъекция в e107 BLOG Engine

Дата публикации:
16.05.2008
Дата изменения:
16.05.2008
Всего просмотров:
1315
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
BLOG Engine 2.x
Уязвимые версии: BLOG Engine (плагин к e107) 2.2, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "rid" в сценарии comment.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Пример:

http://[host]/macgurublog_menu/comment.php?rid=[SQL]

URL производителя: e107coders.org/download.php?view.1843

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA