Переполнение буфера в WordNet

Дата публикации:
15.05.2008
Дата изменения:
15.05.2008
Всего просмотров:
745
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-2149
CVE-2008-3908
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordNet 3.x
Уязвимые версии: WordNet 3.0, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "searchwn()" в файле src/wn.c и в функции "wngrep()" в файле lib/search.c. Удаленный пользователь может с помощью слишком длинного аргумента, отправленного приложению "wn", вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: wordnet.princeton.edu

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA