Межсайтовый скриптинг в cPanel

Дата публикации:
14.05.2008
Всего просмотров:
739
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-2070
CVE-2008-2071
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
cPanel 11.x
Уязвимые версии: cPanel версии до 11.18.4-23888 и 11.22.2-23808

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "issue" в сценарии scripts2/knowlegebase, в параметре "user" в сценарии scripts2/changeip и в параметре "search" в сценарии scripts2/listaccts. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов перед выполнением некоторых действий. Удаленный пользователь может произвести CSRF атаку.

URL производителя: www.cpanel.net

Решение: Установите последнюю версию 11.18.4-23888 или 11.22.2-23808 с сайта производителя.

или введите имя

CAPTCHA