PHP-инклюдинг в SazCart

Дата публикации:
12.05.2008
Дата изменения:
12.05.2008
Всего просмотров:
996
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-2224
CVE-2008-2411
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Sazcart 1.x
Уязвимые версии: SazCart 1.5.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "_saz[settings][site_dir]" в сценарии layouts/default/header.saz.php и в параметре "_saz[settings][site_url]" в сценарии admin/alayouts/default/pages/login.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/layouts/default/header.saz.php?_saz[settings][site_dir]=[file]

URL производителя: sazcart.com/site/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: SazCart <= 1.5.1 (prodid) Remote SQL Injection Exploit

или введите имя

CAPTCHA