Переполнение буфера при обработке PNM изображений в ImageMagick

Дата публикации:
27.04.2005
Дата изменения:
03.05.2008
Всего просмотров:
518
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
ImageMagick 6.x
Уязвимые версии: ImageMagick версии до 6.2.2

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "ReadPNMImage()" при обработке PNM изображений. Удаленный пользователь может с помощью специально сформированного PNM изображения вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www.imagemagick.org

Решение: Установите последнюю версию 6.2.2 с сайта производителя.

или введите имя

CAPTCHA