Множественные уязвимости в PHP

Дата публикации:
02.05.2008
Дата изменения:
01.08.2008
Всего просмотров:
2374
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-0599
CVE-2008-2050
CVE-2008-2051
CVE-2008-2107
CVE-2008-2108
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Обход ограничений безопасности
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP 5.2.x
Уязвимые версии: PHP версии до 5.2.6

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти ограничения безопасности, вызвать отказ в обслуживании и скомпрометировать целевую систему.

1. Уязвимость существует из-за неизвестной ошибки в FastCGI SAPI. Удаленный пользователь может вызвать переполнение стека.

2. Уязвимость существует из-за неизвестной ошибки в функциях "escapeshellcmd()" и "escapeshellarg()" при обработке неполных многобайтных символов. Удаленный пользователь может обойти ограничения безопасности директив "safe_mode_exec_dir" и "disable_functions" и потенциально выполнить произвольные команды на системе.

3. Уязвимость существует из-за ошибки в механизме трансляции пути в файле cgi_main.c. Удаленный пользователь может выполнить произвольный код на целевой системе.

4. Уязвимость существует из-за ошибки в cURL. Злоумышленник может обойти ограничения директивы "safe_mode".

5. Уязвимость существует из-за ошибки проверки границ данных в PCRE. Удаленный пользователь может вызвать отказ в обслуживании или скомпрометировать целевую систему. Подробное описание уязвимости:
www.securitylab.ru/vulnerability/313275.php

URL производителя: www.php.net

Решение: Установите последнюю версию 5.2.6 с сайта производителя.

Журнал изменений:

08.05.2008
Изменено описание уязвимости. Добавлены новые данные.

или введите имя

CAPTCHA