Межсайтовый скриптинг в Drupal Internationalization and Localizer

Дата публикации:
25.04.2008
Дата изменения:
25.04.2008
Всего просмотров:
1709
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-1976
CVE-2008-1977
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal Internationalization Module 5.x
Drupal Localizer Module 5.x
Уязвимые версии:
Drupal Internationalization Module версии до 5.x-2.3 и 5.x-1.1 Drupal Localizer Module 5.x версии до 5.x-3.4, 5.x-2.1 и 5.x-1.11

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов перед выполнением некоторых действий. Удаленный пользователь может произвести CSRF атаку.

URL производителя: drupal.org

Решение: Установите последнюю версию с сайта производителя.

или введите имя

CAPTCHA