Переполнение буфера в SIPp

Дата публикации:
23.04.2008
Дата изменения:
06.05.2008
Всего просмотров:
871
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
SIPp 3.x
Уязвимые версии: SIPp 3.0, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "get_remote_video_port_media()" в файле call.cpp. Удаленный пользователь может с помощью специально сформированного SIP сообщения вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: sipp.sourceforge.net

Решение: Установите последнюю версию 3.1 с сайта производителя.

или введите имя

CAPTCHA