Переполнение буфера в Firefly Media Server

Дата публикации:
21.04.2008
Дата изменения:
21.04.2008
Всего просмотров:
1158
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Firefly Media Server 0.x
Уязвимые версии: Firefly Media Server версии до 0.2.4.2

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за математической ошибки в функции "ws_getpostvars()" в файле src/webserver.c. Удаленный пользователь может с помощью специально сформированного HTTP POST запроса, содержащего отрицательное значение в заголовке "Content-Length", вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www.fireflymediaserver.org/

Решение: Установите последнюю версию 0.2.4.2 с сайта производителя.

или введите имя

CAPTCHA