Переполнение буфера в Acon

Дата публикации:
21.04.2008
Всего просмотров:
1059
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная
Воздействие:
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Acon 1.x
Уязвимые версии: Acon 1.0.5, возможно более ранние версии

Описание:
Уязвимость позволяет локальному пользователю повысить свои привилегии на системе.

Уязвимость существует из-за ошибок проверки границ данных в файлах acon.c, menu.c и child.c. Локальный пользователь может с помощью слишком длинной переменной окружения $HOME или большого количества терминальных колонок вызвать переполнение стека в setuid приложении "acon" и выполнить произвольный код на целевой системе.

URL производителя: members.tripod.com/ahmedahamid/arabic/arabic.html#Acon

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA