Переполнение буфера в SubEdit Player

Дата публикации:
21.04.2008
Всего просмотров:
824
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
SubEdit Player 1.x
Уязвимые версии: SubEdit Player build 4066 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке субтитров. Удаленный пользователь может с помощью специально сформированного файла, содержащего слишком длинную строку, вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: alfa.icis.pcz.pl/~subedit/english/information.html

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: SubEdit Player build 4066 subtitle Buffer Overflow PoC

или введите имя

CAPTCHA