Переполнение буфера в xine-lib

Дата публикации:
17.04.2008
Дата изменения:
18.08.2008
Всего просмотров:
1123
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
xine-lib 1.x
Уязвимые версии:xine-lib 1.1.12, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "demux_nsf_send_chunk()" в файле src/demuxers/demux_nsf.c. Удаленный пользователь может с помощью слишком длинного NSF заголовка вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: xinehq.de

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:


10.08.2008
Изменена секция "Решение".

Ссылки: xine-lib <= 1.1.12 NSF demuxer Stack Overflow Vulnerability PoC

или введите имя

CAPTCHA