Множественные уязвимости в cpCommerce

Дата публикации:
14.04.2008
Дата изменения:
14.04.2008
Всего просмотров:
1182
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-1906
CVE-2008-1907
CVE-2008-1908
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Раскрытие системных данных
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
cpCommerce 1.x
Уязвимые версии: cpCommerce 1.1.0, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, выполнить произвольные SQL команды и получить доступ к важным данным.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "year" в сценарии calendar.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "id_product", "id_manufacturer" и "id_category" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметре "language" в сценарии index.php и в параметре "action" в сценарии category.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

URL производителя: cpcommerce.cpradio.org

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA