Несколько уязвимостей в 1024 CMS

Дата публикации:
14.04.2008
Всего просмотров:
1291
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
1024 CMS 1.x
Уязвимые версии: 1024 CMS 1.4.1, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольные SQL команды в базе данных приложения и получить доступ к важным данным на системе.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "cookpass" файла куки в сценарии includes/system.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "lang" в сценарии pages/print/default/ops/news.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе. Для успешной эксплуатации уязвимости опция "register_globals" должна быть включена и опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

URL производителя: 1024cms.com/index.php

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: 1024 CMS <= 1.4.2 Local File Inclusion / Blind SQL Injection Exploit

или введите имя

CAPTCHA