PHP-инклюдинг в NewsOffice

Дата публикации:
14.04.2008
Дата изменения:
14.04.2008
Всего просмотров:
900
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
NewsOffice 1.x
Уязвимые версии: NewsOffice 1.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "newsoffice_directory" в сценарии news_show.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/news_show.php?newsoffice_directory=[file]

URL производителя: www.newanz.com/applications/NewsOffice/

Решение: Установите последнюю версию 1.1.1 с сайта производителя.

или введите имя

CAPTCHA