SQL-инъекция в phpkb Knowledge Base

Дата публикации:
14.04.2008
Дата изменения:
18.08.2008
Всего просмотров:
1180
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-1909
CVE-2008-5088
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpkb Knowledge Base 1.x
phpkb Knowledge Base 2.x
Уязвимые версии: phpkb Knowledge Base 1.5 и 2.0, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "ID" в сценарии comment.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Пример:

http://[host]/comment.php?ID=[SQL]

URL производителя: www.knowledgebase-script.com/

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:


10.08.2008
Изменена секция "Решение".

или введите имя

CAPTCHA