Несколько уязвимостей в KnowledgeQuest

Дата публикации:
10.04.2008
Дата изменения:
11.04.2008
Всего просмотров:
825
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-1726
CVE-2008-1727
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
KnowledgeQuest 2.x
Уязвимые версии: KnowledgeQuest 2.6, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти ограничения безопасности и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "kqid" в сценариях articletext.php и articletextonly.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "username" в сценарии logincheck.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

3. Уязвимость существует из-за недостаточного ограничения доступа в сценарии admincheck.php. Удаленный пользователь может добавить административного пользователя.

URL производителя: www.myknowledgequest.com

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA