Несколько уязвимостей в GNU M4

Дата публикации:
08.04.2008
Дата изменения:
10.04.2008
Всего просмотров:
1826
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-1687
CVE-2008-1688
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GNU M4 1.x
Уязвимые версии: GNU M4 1.4.10, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности и скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки форматной строки в функции "produce_frozen_state()" в файле src/freeze.c. Злоумышленник может с помощью специально сформированного имени файла, указанного в качестве параметра к "m4 -F", выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки в реализации макросов "maketemp" и "mkstemp", которая позволяет с помощью символов, находящихся в выходной строке, спровоцировать обработку неподходящих файлов.

URL производителя: www.gnu.org/software/m4/

Решение: Установите последнюю версию 1.4.11 с сайта производителя.

или введите имя

CAPTCHA