PHP-инклюдинг в Blogator-script

Дата публикации:
07.04.2008
Дата изменения:
07.04.2008
Всего просмотров:
1329
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-1763
CVE-2008-1892
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Blogator-script 0.x
Blogator-script 1.x
Уязвимые версии: Blogator-script 1.01 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "incl_page" в сценариях struct_admin.php, struct_admin_blog.php и struct_main.php в каталоге "_blogadata/include". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/_blogadata/include/struct_admin.php?incl_page=[file]

URL производителя: www.blogator-script.com

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA