Повреждение памяти в GnuPG

Дата публикации:
02.04.2008
Всего просмотров:
1189
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GnuPG / gpg 1.4.x
GnuPG / gpg 2.x
Уязвимые версии:
GnuPG / gpg 1.4.8, возможно более ранние версии
GnuPG / gpg 2.0.8, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки при импортировании ключей с одинаковыми идентификаторами. Злоумышленник может вызвать повреждение памяти и выполнить произвольный код на целевой системе, если ключи импортируются посредством --refresh-keys или --import.

URL производителя: www.gnupg.org

Решение: Установите последнюю версию 1.4.9 или 2.0.9 с сайта производителя.

или введите имя

CAPTCHA