Переполнение буфера в Linux Audit

Дата публикации:
31.03.2008
Всего просмотров:
1067
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная
Воздействие:
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Linux Audit 1.x
Уязвимые версии: Linux Audit версии до 1.7

Описание:
Уязвимость позволяет локальному пользователю повысить свои привилегии на системе.

Уязвимость существует из-за ошибки проверки границ данных в функции audit_log_user_command()" в файле lib/audit_logging.c. Локальный пользователь может с помощью слишком длинного аргумента "command" вызвать переполнение стека и выполнить произвольный код на системе с привилегиями приложения, использующего библиотеку libaudit.

URL производителя: people.redhat.com/sgrubb/audit/

Решение: Установите последнюю версию 1.7 с сайта производителя.

или введите имя

CAPTCHA