Несколько уязвимостей в CuteFlow

Дата публикации:
31.03.2008
Всего просмотров:
961
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-1630
CVE-2008-1631
CVE-2008-1632
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CuteFlow 1.x
CuteFlow 2.x
Уязвимые версии: CuteFlow 2.10.0 и более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "UserId" в сценарии login.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "listid" в сценарии pages/editmailinglist_step1.php, в параметре "userid" в сценарии pages/edituser.php, в параметре "fieldid" в сценарии pages/editfield.php и в параметре "templateid" в сценарии pages/edittemplate_step1.php и потенциально в других параметрах и сценариях. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметре "language" в сценариях pages/showcirculation.php, pages/edittemplate_step2.php, pages/showfields.php, pages/showuser.php, pages/editmailinglist_step1.php и pages/showtemplates.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: cuteflow.org

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA