Множественные уязвимости в VLC Media Player

Дата публикации:
25.03.2008
Дата изменения:
28.04.2008
Всего просмотров:
1733
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-0073
CVE-2008-1489
CVE-2008-1768
CVE-2008-1769
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
VLC Media Player 0.x
Уязвимые версии: VLC Media Player 0.8.6e, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю скомпрометировать целевую систему.

1. Целочисленное переполнение обнаружено в функции "MP4_ReadBox_rdrf()" в файле modules/demux/mp4/libmp4.c. Удаленный пользователь может с помощью MP4 файла, содержащего специально сформированный RDRF атом вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки проверки границ данных в функции "sdpplin_parse()" в файле modules/access/rtsp/real_sdpplin.c. Удаленный пользователь может перезаписать произвольные участки памяти и выполнить произвольный код на целевой системе.

3. Два целочисленных переполнения обнаружено в функции "cinepak_decode_frame()" в modules/codec/cinepak.c. Удаленный пользователь может вызвать переполнении динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www.videolan.org/vlc/

Решение: Установите последнюю версию 0.8.6f с сайта производителя.

Журнал изменений:

24.04.2008
Добавлены уязвимости # 2, 3
Изменена секция «Решение».

или введите имя

CAPTCHA