Несколько уязвимостей в EasyCalendar

Дата публикации:
14.03.2008
Дата изменения:
14.03.2008
Всего просмотров:
1063
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-1344
CVE-2008-1345
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
EasyCalendar 4.x
Уязвимые версии: EasyCalendar 4.0tr, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "year" в сценарии plugins/calendar/calendar_backend.php и в параметре "page" в сценарии ajaxp_backend.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Пример:

http://[host]/plugins/calendar/calendar_backend.php?pageec=dayview&month=2&year=-1[SQL]

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "day" в сценарии plugins/calendar/calendar_backend.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: myiosoft.com/?1.5.0.0

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA