Несколько уязвимостей в EasyGallery

Дата публикации:
14.03.2008
Дата изменения:
14.03.2008
Всего просмотров:
1071
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-1346
CVE-2008-1347
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
EasyGallery 5.x
Уязвимые версии: EasyGallery 5.00tr, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "catid" в сценарии staticpages/easygallery/index.php (когда параметр "page" установлен в значение "category"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Пример:

http://[host]/staticpages/easygallery/index.php?page=category&PageSection=0&catid=[SQL]

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "q" и в URL в сценарии staticpages/easygallery/index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: myiosoft.com/?1.9.0.0

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA