Несколько уязвимостей в Mapbender

Дата публикации:
13.03.2008
Всего просмотров:
984
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-0300
CVE-2008-0301
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Mapbender 2.x
Уязвимые версии: Mapbender 2.4.4, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести SQL-инъекцию и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "factor" в сценарии tools/mapFiler.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе.

URL производителя: www.mapbender.org

Решение: Установите последнюю версию 2.4.5 rc1 с сайта производителя.

или введите имя

CAPTCHA