Множественные уязвимости в Adobe ColdFusion

Дата публикации:
12.03.2008
Дата изменения:
12.03.2008
Всего просмотров:
1083
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-0643
CVE-2008-0644
CVE-2008-1203
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Adobe ColdFusion MX 7.x
Adobe ColdFusion 8.x
Уязвимые версии: Adobe ColdFusion MX 7.x, 8.x

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности и произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в CGI переменных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Уязвимости подвержены лишь продукты ColdFusion установленные с Microsoft IIS 6.

2. Уязвимость существует из-за неизвестной ошибки, которая позволяет обойти механизм защиты от XSS атак, когда "Application.cfm" или "Application.cfc" содержат функцию setEncoding.

3. Уязвимость существует из-за того, что приложение не ведет журнал неудачных попыток входа в административный интерфейс.

URL производителя: www.adobe.com

Решение: Установите исправление с сайта производителя.

Ссылки: APSB08-06: Update available for potential ColdFusion MX 7 and ColdFusion 8 Cross Site Scripting security issue
APSB08-07: Update available for ColdFusion MX 7 and ColdFusion 8 Cross-Site Scripting issue
APSB08-08: Update available for ColdFusion MX 7 and ColdFusion 8 logs invalid admin interface log-in attempts

или введите имя

CAPTCHA