Множественные уязвимости в MailEnable

Дата публикации:
10.03.2008
Дата изменения:
07.04.2008
Всего просмотров:
1079
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-1276
CVE-2008-1277
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MailEnable Professional 3.x
MailEnable Enterprise Edition 3.x
Уязвимые версии:
MailEnable Enterprise Edition 3.13, возможно более ранние версии
MailEnable Professional 3.13, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки проверки границ данных в службе IMAP (MEIMAPS.EXE) при обработке аргументов, передаваемы командам FETCH, EXAMINE и UNSUBSCRIBE. Удаленный авторизованный пользователь может с помощью слишком длинного аргумента вызвать переполнение буфера и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки в службе IMAP при обработке команд SEARCH и APPEND. Удаленный пользователь может с помощью специально сформированной команды аварийно завершить работу службы.

URL производителя: www.mailenable.com

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:


07.04.2008
Изменена секция "Решение".

Ссылки: MailEnable Professional/Enterprise <= 3.13 Denial of Service PoC

или введите имя

CAPTCHA