Переполнение буфера в Programmers Notepad

Дата публикации:
06.03.2008
Дата изменения:
07.03.2008
Всего просмотров:
1373
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Programmers Notepad 2.x
Уязвимые версии: Programmer's Notepad 2.0.6.1, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке выходных ctags данных. Удаленный пользователь может с помощью специально сформированного ".c" файла вызвать переполнение стека и выполнить произвольный код на целевой системе. Для успешной эксплуатации уязвимости пользователь должен использовать диалоговое окно "Jump To".

URL производителя: www.pnotepad.org

Решение: Установите последнюю версию 2.0.8.718 с сайта производителя.

или введите имя

CAPTCHA