Переполнение буфера в SILC Toolkit

Дата публикации:
05.03.2008
Всего просмотров:
1130
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
SILC Secure Internet Live Conferencing Toolkit 1.x
Уязвимые версии: SILC Secure Internet Live Conferencing Toolkit версии до 1.1.6

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "silc_fingerprint()" в файле lib/silcutil/silcutil.c. Удаленный пользователь может передать уязвимой функции слишком большое количество данных, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: silcnet.org/software/download/toolkit/

Решение: Установите последнюю версию 1.1.6 с сайта производителя.

или введите имя

CAPTCHA