Переполнение буфера в Ghostscript

Дата публикации:
28.02.2008
Дата изменения:
07.04.2008
Всего просмотров:
988
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ghostscript 8.x
Уязвимые версии: Ghostscript 8.61, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "zseticcspace()" в файле zicc.c. Удаленный пользователь может с помощью специально сформированного PostScript (.ps) файла , содержащего слишком длинный массив "Range", вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.ghostscript.com

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:


07.04.2008
Изменена секция "Решение".

Ссылки: Ghostscript <= 8.61 Buffer Overflow PoC

или введите имя

CAPTCHA