Переполнение буфера в VLC Media Player

Дата публикации:
27.02.2008
Дата изменения:
16.03.2008
Всего просмотров:
1572
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
VLC Media Player 0.x
Уязвимые версии: VLC Media Player 0.8.6d, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в MP4 demuxer (modules/demux/mp4/mp4.c). Удаленный пользователь может с помощью специально сформированного MPEG-4 файла перезаписать произвольные участки памяти и выполнить произвольный код на целевой системе.

URL производителя: www.videolan.org/vlc/

Решение: Установите последнюю версию 0.8.6e с сайта производителя.

Журнал изменений:

16.03.2008
Изменена секция «Решение».

или введите имя

CAPTCHA