Переполнение буфер в activePDF Server

Дата публикации:
27.02.2008
Всего просмотров:
843
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
activePDF Server 3.8.x
Уязвимые версии: activePDF Server 3.8.4 и 3.8.5.14, возможно другие версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в службе activePDF Server (APServer.exe). при получении клиентских данных. Удаленный пользователь может получиться к службе, слушающей на порту 53535/TCP, отправить специально сформированный пакет, вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www.activepdf.com/products/serverproducts/server/index.cfm

Решение: Установите последнюю версию 3.8.6.16 с сайта производителя.

Ссылки: Secunia Research: activePDF Server Packet Handling Buffer Overflow

или введите имя

CAPTCHA