Переполнение буфера в Novell iPrint Client

Дата публикации:
22.02.2008
Всего просмотров:
1230
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Novell iPrint Client 4.x
Уязвимые версии: Novell iPrint Client 4.26 и 4.32, возможно другие версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в Novell iPrint Control ActiveX компоненте (ienipp.ocx) при обработке метода "ExecuteRequest()". Удаленный пользователь может с помощью специально сформированного web сайта передать слишком длинный аргумент (более 256 байт) уязвимому методу, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.novell.com

Решение: Установите последнюю версию 4.34 с сайта производителя.

или введите имя

CAPTCHA