Несколько уязвимостей в PunBB

Дата публикации:
22.02.2008
Всего просмотров:
2988
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-1484
CVE-2008-1485
Вектор эксплуатации:
Удаленная
Воздействие:
Брут-форс атака
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PunBB 1.x
Уязвимые версии: PunBB 1.2.16, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и произвести брут-форс атаку.

1. Уязвимость существует из-за ошибки в генераторе случайных чисел в функционале "Forgotten your password?". Злоумышленник может обнулить пароли пользователей, включая администраторов приложения. Для успешной эксплуатации уязвимости требуются валидные учетные данные.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "get_host" в сценарии moderate.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости целевой пользователь должен иметь привилегии модератора.

URL производителя: www.punbb.org

Решение: Установите последнюю версию 1.2.17 с сайта производителя.

Ссылки: PunBB <= 1.2.16 Blind Password Recovery Exploit

или введите имя

CAPTCHA