Множественные уязвимости в MoinMoin

Дата публикации:
21.02.2008
Дата изменения:
21.02.2008
Всего просмотров:
981
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-0780
CVE-2008-0781
CVE-2008-0782
CVE-2008-1098
CVE-2008-1099
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Отказ в обслуживании
Обход ограничений безопасности
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MoinMoin 1.x
Уязвимые версии: MoinMoin версии до 1.6.1

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, вызвать отказ в обслуживании и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "name" на странице входа. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в сценарии action/AttachFile.py. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметре куки MOIN_ID. Удаленный пользователь может с помощью символов обхода каталога перезаписать произвольные файлы на системе.

URL производителя: moinmo.in

Решение: Установите последнюю версию 1.6.1 с сайта производителя.

Ссылки: MoinMoin 1.5.x MOIND_ID cookie Bug Remote Exploit

или введите имя

CAPTCHA