Множественные уязвимости в JSPWiki

Дата публикации:
14.02.2008
Дата изменения:
14.02.2008
Всего просмотров:
952
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-1229
CVE-2008-1230
CVE-2008-1231
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
JSPWiki 2.x
Уязвимые версии: JSPWiki версии до 2.6.1

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, получить доступ к важным данным и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "editor" в сценарии Edit.jsp. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "editor" в сценарии Edit.jsp. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе.

URL производителя: www.jspwiki.org

Решение: Установите последнюю версию 2.6.1 с сайта производителя.

или введите имя

CAPTCHA