Переполнение буфера в PCRE

Дата публикации:
14.02.2008
Дата изменения:
02.05.2008
Всего просмотров:
1744
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PCRE 7.x
Уязвимые версии: PCRE версии до 7.6

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке классов символов. Злоумышленник может с помощью слишком длинного класса символов, с кодом более 255, вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: www.pcre.org

Решение: Установите последнюю версию 7.6 с сайта производителя.

или введите имя

CAPTCHA