Несколько уязвимостей в MercuryBoard

Дата публикации:
12.02.2008
Дата изменения:
20.05.2008
Всего просмотров:
1509
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MercuryBoard 1.x
Уязвимые версии: MercuryBoard 1.1.5, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "message" в сценарии index.php во время предварительного просмотра частного сообщения. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в сценарии login.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: www.mercuryboard.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: MercuryBoard <= 1.1.5 (login.php) Remote Blind SQL Injection Exploit

или введите имя

CAPTCHA