Выполнение произвольного PHP кода в SAPID CMF

Дата публикации:
11.02.2008
Всего просмотров:
5550
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
SAPID CMF
Уязвимые версии: SAPID CMF build 90 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "last_module" в сценарии vendors/adodb_lite/adodb-perf-module.inc.php перед вызовом функции "eval()". Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/vendors/adodb_lite/adodb-perf-module.inc.php?last_module=[PHP Code]

URL производителя: sapidcmf.sourceforge.net

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA