Переполнение буфера в UltraVNC

Дата публикации:
08.02.2008
Всего просмотров:
2630
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
UltraVNC (ранее Ultr@VNC) 1.x
Уязвимые версии: UltraVNC 102 и 1.0.4 до 04.02.2008, возможно другие версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимости существуют из-за различных ошибок проверки границ данных в файле vncviewer/FileTransfer.cpp. Злоумышленник может обманом заставить пользователя подключится к злонамеренному VNC серверу, отправить vncviewer в режиме "LISTENING" специально сформированные данные и выполнить произвольный код на целевой системе.

URL производителя: ultravnc.sourceforge.net

Решение: Установите последнюю версию с сайта производителя.

или введите имя

CAPTCHA