Межсайтовый скриптинг в WordPress WP-Footnotes

Дата публикации:
04.02.2008
Дата изменения:
04.02.2008
Всего просмотров:
1533
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WP-Footnotes 2.x (plugin for WordPress)
Уязвимые версии: WP-Footnotes (плагин к WordPress) 2.2, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в элементах "pre_footnotes", "priority", "post_footnotes" и "style_rules" массива "wp_footnotes_current_settings[]" в сценарии admin_panel.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: www.elvery.net/drzax/more-things/wordpress-footnotes-plugin/

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA