Переполнение буфера в Aurigma Image Uploader ActiveX компоненте

Дата публикации:
04.02.2008
Дата изменения:
19.08.2008
Всего просмотров:
1739
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Aurigma Image Uploader 4.x
Aurigma Image Uploader 5.x
Уязвимые версии: Aurigma Image Uploader 4.6.17.0, 5.0.15.0 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в Image Uploader Control ActiveX компоненте при обработке свойств ExtractIptc и ExtractExif. Удаленный пользователь может с помощью специально сформированного Web сайта передать слишком длинную строку уязвимому свойству, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.facebook.com/

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:


10.08.2008
Изменена секция "Решение".

Ссылки: FaceBook PhotoUploader (ImageUploader4.ocx 4.5.57.0) BOF Exploit

или введите имя

CAPTCHA