Переполнение буфера в FaceBook PhotoUploader ActiveX компоненте

Дата публикации:
04.02.2008
Дата изменения:
04.02.2008
Всего просмотров:
1284
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-0660
CVE-2008-5711
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Facebook Photo Uploader 4.x
Уязвимые версии: FaceBook Photo Uploader ActiveX версии до 4.5.57.1

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в TheFacebook.FacebookPhotoUploader4.4.1 ActiveX компоненте (ImageUploader4.1.ocx) при обработке свойств ExtractIptc и ExtractExif. Удаленный пользователь может с помощью специально сформированного Web сайта передать слишком длинную строку уязвимому свойству, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.facebook.com/

Решение: Установите последнюю версию 4.5.57.1 с сайта производителя.

Журнал изменений:

04.02.2008
Обновлено описание уязвимости.

Ссылки: FaceBook PhotoUploader (ImageUploader4.ocx 4.5.57.0) BOF Exploit

или введите имя

CAPTCHA