Переполнение буфера в IpSwitch WS_FTP Server

Дата публикации:
04.02.2008
Дата изменения:
29.03.2009
Всего просмотров:
1107
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WS_FTP Server 6.x
Уязвимые версии: IpSwitch WS_FTP Server 6.x

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в SSH Server Service (SSHServer.exe) при обработке аргументов к команде "opendir". Злоумышленник может передать слишком длинный аргумент уязвимой команде, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.ipswitch.com/products/ws_ftp-server/index.asp

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
29.03.2009
Изменена секция "Решение"

Ссылки: IpSwitch WS_FTP Server with SSH 6.1.0.0 Remote Buffer Overflow PoC

или введите имя

CAPTCHA