Переполнение буфера в UltraVNC

Дата публикации:
01.02.2008
Дата изменения:
01.02.2008
Всего просмотров:
1807
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
UltraVNC (ранее Ultr@VNC) 1.x
Уязвимые версии: UltraVNC 1.0.4 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за недостаточной проверки границ данных в функции "ClientConnection::NegotiateProtocolVersion()" в файле vncviewer/ClientConnection.cpp. Злоумышленник может обманом заставить пользователя подключиться к злонамеренному серверу и отправить специально сформированные данные приложению в режиме "LISTENING", вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: ultravnc.sourceforge.net

Решение: Установите исправление с сайта производителя.
http://downloads.sourceforge.net/ultr...traVNC-Viewer-104-Security-Update.zip

или введите имя

CAPTCHA